Investigating issues with Google integration
Incident Report for Mashme
Resolved
The incident has been resolved.
Posted Dec 14, 2020 - 14:17 UTC
Monitoring
All services are restored now, according to the google status page.

We can confirm that all affected services in mashme are now working but we will continue monitoring closely the platform status.


Regards.
Posted Dec 14, 2020 - 12:58 UTC
Update
Mashme services affected by the outage:

> Google - SSO with google as IdP
> Google - Drive integration
> Google - Youtube search and play
> Google - Apps documents creation and edition

So far, the only google related service not affected by their outage is:
> Google - Maps

We are also monitoring temporary issues with
> Mashme - Recording
> Mashme - File upload
> Mashme - Room launch


We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Dec 14, 2020 - 12:33 UTC
Identified
Google has already reported an outage related to most of the cloud service. More information is available here:

https://www.google.com/appsstatus#hl=en&v=status

We are analyzing if the impact of this outage could affect more components of the mashme platform.

We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Dec 14, 2020 - 12:21 UTC
Investigating
We’re currently investigating reports of a service interruption with several Google-related services (Youtube, Drive, Apps...).

We can confirm that the features related to these 3rd party services are not working in production:

> Youtube video search
> Drive integration
> New Google document
> Maps

Also, the recording service can be affected since it relies on the google infrastructure APIs to provide the service.

We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Dec 14, 2020 - 12:16 UTC
This incident affected: ROOM OF THE FUTURE (ROOM OF THE FUTURE - PLATFORM, ROOM OF THE FUTURE - ACCOUNTS PORTAL, ROOM OF THE FUTURE - ANALYTICS PORTAL, ROOM OF THE FUTURE - TEST PAGE).